Top > diary > 2010-10-18

taru.webhop.netサーバー Edit

 とりあえず一通りの設定をしてtaru.webhop.netサーバーの再セットアップは完了したのだが、HDDの状態を確認してみると、またもやsdb(RAIDコピー側のHDD)が認識されていない(止まっている)事を示す情報が出力されました。後で再起動して色々とチェックしてみますが、過激な事をやって再び起動不可能になるかもしれません・・・。

[root@xxxx ~]# cat /proc/mdstat
Personalities : [raid1] 
md0 : active raid1 sda1[0]
      104320 blocks [2/1] [U_]
      
md1 : active raid1 sda2[0]
      312464128 blocks [2/1] [U_]
      
unused devices: <none>
[root@xxxx ~]# fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = シリンダ数 of 16065 * 512 = 8225280 bytes

デバイス Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   fd  Linux raid 自動検出
/dev/sda2              14       38913   312464250   fd  Linux raid 自動検出

Disk /dev/md1: 319.9 GB, 319963267072 bytes
2 heads, 4 sectors/track, 78116032 cylinders
Units = シリンダ数 of 8 * 512 = 4096 bytes

ディスク /dev/md1 は正常な領域テーブルを含んでいません

 taru.webhop.netサーバー側に書いた2回分の記事はバックアップが取れていなかったので消滅しました。大した内容では無かったのですが、無くなると悲しいですね。

 Mondo Rescueにてとったバックアップを、リストアするチャンスと思い色々試して粘ってみたのですが、経験不足と知識不足な自分ではこれ以上無理と判断して断念しました。

  • バックアップに使った8GBのUSBメモリーが、USB boot に対応していなかった。
     →4GBのUSBメモリーにboot環境を構築し、内容をコピーした。
  • 使用したパソコンではUSBメモリーを最初のデバイスとして名前を付けて認識する。
     →HDDのbootパーティションに、MondoRescue用のbootファイルをコピーして、GRUBから指定bootすることで、USBを外した状態でHDDデバイスを最初に認識させる。
    (この方法は、幾つかのデバイスを手動コマンドで認識させる必要があります)
  • バックアップの内容をリストアするときに一度全てメモリーに展開するのか、1GBだと21%まで、4GBだと90%までメーターが進んだところで終了してしまう。
     →USB外付けHDDをLinux-swapとしてフォーマットしてコマンドでswapとして手動認識させましたが、MondoRescueはswapを利用してくれませんでした。
     →8GBのメモリー購入も考えましたが、Intel D510MOのメモリーは4GBまでしか認識しない仕様なのとDDR2って事でボツになりました。

Reload   New Lower page making Edit Freeze Diff Upload Copy Rename   Front page List of pages Search Recent changes Backup Referer   Help   RSS of recent changes